Windows update does not work

Discussion in 'Windows 8 Support' started by ju1234, Mar 28, 2019.

  1. ju1234

    ju1234

    Joined:
    Mar 28, 2019
    Messages:
    1
    Likes Received:
    0
    Hello,

    I have Windows 8.1 on Toshiba C75D-B3700. About 6 moths ago, I installed SSD and restored the original Windows to that. Reinstalled all the apps etc. The Windows update history shows last update on 12/11/2018. The update is set to "Auto" and I have not received any error messages or any thing telling me that updates is not working. But recently i installed an app. When I start the app, I get an error: "program can't start because api-ms-win-crt-studio-l1-1-0.dll is missing". Reinstalling the app did not fix problem. Contacting the app people told me "you need to update windows". That is when I realized that it is not working right.


    The Windows update is not working. It is set on auto. But when I do "check updates now" it starts looking and those dots keep going for ever. I ran the Windows update troubleshooting. The windows update.diagcab. It supposedly fixed couple of things but still unable to update. I ran it few times and restarted computer, still same.


    Then I followed the directions in another link here. The first step: sfc/scannow "found corrupt files but was unable to fix some". Then I did Dism.exe/online /cleanup-image /restorehealth. Result was Image version 6.3.9600.17031 ==============100.0%======== error 0x80240021. Dism failed. No operation performed. Then I tried to do rename c:\softwareDistribution softwaredistribution.old. It says "access denied".


    So, what else can I do? Thanks.
     
    ju1234, Mar 28, 2019
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.