Virtual Box and computer performance

Discussion in 'General Discussion' started by kingsindian, Mar 4, 2012.

  1. kingsindian

    kingsindian

    Joined:
    Mar 1, 2012
    Messages:
    10
    Likes Received:
    0
    Here are my performance scores. I am using virtual box in a quad core windows 7. Any suggestions to keep virtual box and improve these scores is appreciated. Its running very sluggish for 8 but not bad for a single core. This is the 86.

    Processor 4.4
    Memory 5.7
    Graphics 2.0
    Gaming graphics 2.2
    primary hard disk 6.6

    Is there anyway to increase the graphics within virtual box. I'm getting a warning that my 32mb setting is at 20 mb but am unsure if I can change it now and if so how.

    Graphics

    Total Graphics 256 mb
    dedicated graphics memory 0
    dedicated system memory 0
    shared system memory 256
    Direct x verison 11 or better
     
    kingsindian, Mar 4, 2012
    #1
    1. Advertisements

  2. kingsindian

    Ian Administrator

    Joined:
    Jan 26, 2010
    Messages:
    552
    Likes Received:
    76
    Location:
    UK
    Performance in VirtualBox will always be limited, but you may be able to improve things by enabling 2D/3D acceleration. If you go to the VM settings > Display, you should be able to tick two boxes for "3D Acceleration" and "2D Video Acceleration". You'll probably also need to increase the video memory (try 128MB if you can).
     
    Ian, Mar 5, 2012
    #2
    1. Advertisements

  3. kingsindian

    kingsindian

    Joined:
    Mar 1, 2012
    Messages:
    10
    Likes Received:
    0
    One other question? Virtual box says you have the auto captured keyboard turned on. I can only work inside the box. Can I change that to a more preferrable setting and also no usb? Can I also change that function in virtual box? Thank you for the other reply am in process of testing it out.
     
    kingsindian, Mar 5, 2012
    #3
  4. kingsindian

    Ian Administrator

    Joined:
    Jan 26, 2010
    Messages:
    552
    Likes Received:
    76
    Location:
    UK
    You can disable USB support in the settings (Settings > USB > untick "Enable USB Controller"). I'm not sure I understand the auto-capture keyboard question, but if you install the virtual box "guest addition" (from the Devices menu once you're booted in to Windows 8), then you will get better mouse/keyboard integration.
     
    Ian, Mar 5, 2012
    #4
  5. kingsindian

    kingsindian

    Joined:
    Mar 1, 2012
    Messages:
    10
    Likes Received:
    0
    Thanks for the help. I continually get error messages while logging on. Runs kind of slow compared to my windows 7 but works fairly well in the box.
     
    kingsindian, Mar 7, 2012
    #5
  6. kingsindian

    draceena

    Joined:
    Jan 31, 2011
    Messages:
    11
    Likes Received:
    0
    Location:
    New Brunswick
    Guest Editions is not working well in Win 8 yet, the biggest issue it seems is with the video driver
     
    draceena, Mar 7, 2012
    #6
  7. kingsindian

    kingsindian

    Joined:
    Mar 1, 2012
    Messages:
    10
    Likes Received:
    0
    Here are my windows 7 performance numbers:
    processor 6.9
    memory 7.2
    graphics 4.1
    gaming graphics 5.4
    primary hard dks 5.9
     
    kingsindian, Mar 7, 2012
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.