Sysprep with Unattend.xml, not setting correct language

SOLVED Discussion in 'Installation, Setup and Upgrades' started by Dezza, Aug 31, 2015.

  1. Dezza

    Dezza

    Joined:
    Aug 31, 2015
    Messages:
    2
    Likes Received:
    0
    Hi Everyone,

    We are trying to create a Windows 8.1 image and have been having a little trouble with the language settings after running sysprep.exe with an unattend.xml file. Everything is working how we want it to work except the language settings after oobe has run etc.

    The sysprep command we run is: sysprep.exe /generalize /oobe /shutdown /unattend:unattend.xml

    Before running sysprep we are setting the language settings to have English (Australia) as the preferred langauge with the Date, time and number formatting.

    [​IMG]

    After sysprep / oobe etc has been run it is changing it to English (US) as the preferred language with the Date, time and number formatting.

    [​IMG]

    We have tried numerous different things with our Unattend.xml file without success. The following code is the latest file we are using, would very much appreciate any help/advice to solve this issue!

    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="generalize">
            <component name="Microsoft-Windows-Security-SPP" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SkipRearm>0</SkipRearm>
            </component>
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <DoNotCleanTaskBar>true</DoNotCleanTaskBar>
                <RegisteredOwner>NHS</RegisteredOwner>
                <RegisteredOrganization>NHS</RegisteredOrganization>
            </component>
        </settings>
        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>en-AU</InputLocale>
                <SystemLocale>en-AU</SystemLocale>
                <UILanguage>en-US</UILanguage>
                <UserLocale>en-AU</UserLocale>
            </component>
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <OOBE>
                    <HideEULAPage>true</HideEULAPage>
                    <NetworkLocation>Work</NetworkLocation>
                    <ProtectYourPC>1</ProtectYourPC>
                    <HideLocalAccountScreen>true</HideLocalAccountScreen>
                    <HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>
                    <HideOnlineAccountScreens>true</HideOnlineAccountScreens>
                    <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
                </OOBE>
                <RegisteredOrganization>NHS</RegisteredOrganization>
                <RegisteredOwner>NHS</RegisteredOwner>
                <TimeZone>Cen. Australia Standard Time</TimeZone>
                <UserAccounts>
                    <LocalAccounts>
                        <LocalAccount wcm:action="add">
                            <Password>
                                <Value>cABhAHMAcwB3AG8AcgBkAFAAYQBzAHMAdwBvAHIAZAA=</Value>
                                <PlainText>false</PlainText>
                            </Password>
                            <Description>tempaccount</Description>
                            <DisplayName>tempaccount</DisplayName>
                            <Group>Administrators</Group>
                            <Name>tempaccount</Name>
                        </LocalAccount>
                    </LocalAccounts>
                </UserAccounts>
                <DoNotCleanTaskBar>true</DoNotCleanTaskBar>
            </component>
        </settings>
        <settings pass="specialize">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <CopyProfile>true</CopyProfile>
                <ComputerName>*</ComputerName>
            </component>
            <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>en-AU</InputLocale>
                <SystemLocale>en-AU</SystemLocale>
                <UILanguage>en-US</UILanguage>
                <UserLocale>en-AU</UserLocale>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="wim:x:/windows%208.1%20dvd/sources/install.wim#Windows 8.1 Enterprise" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>
    
     
    Dezza, Aug 31, 2015
    #1
    1. Advertisements

  2. Dezza

    Dezza

    Joined:
    Aug 31, 2015
    Messages:
    2
    Likes Received:
    0
    I think my problem is solved!

    It seems that it is only when I login with the local user account that I used to setup the image (the one that gets copied to default user) that has the incorrect language settings. If I login with a new user account it has the correct settings.

    I'm wondering if this has something to do with running 'Sysprep.exe' using that user account and whether that changes the language settings for that account? If anyone could explain why this might be I would be very interested!
     
    Dezza, Sep 2, 2015
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.